Excel 365 : Comment extraire doublon d’une plage sur Excel en moins de 6 min.

Problématique :

Comment extraire doublon sur excel d’une plage?

Bonjour à vous toutes et vous tous merci de m’accueillir dans votre groupe

Bonjour je remonte le post

j’utilise recherchev pour extraire des produits par la référence sur ma page catalogue

il existe des refs en doublon dans ma base que je ne veux pas supprimer mais exploiter

Comment extraire doublon d’une plage Excel?

Existe t’il une formule pour extraire les doublons dans ma feuille catalogue merci et bon Lundi dimanche

Solution :

Utilisation d’une formule Sommeprod, combiné à un peu de VBA et de la Mise en forme conditionnelle, voici une solution.

MÉTHODES :

Excel 365 : Comment extraire doublon d'un plage sur Excel en moins de 6 min.
Excel 365 : Comment extraire doublon d’une plage sur Excel en moins de 6 min.

On veut  Extraire les doublons

Mise en forme conditionnelle :

Utilisation de Sommeprod

Afin d’identifier les doublons dans la plage

En E6:  =SOMMEPROD(($A$2:$A$100=$A2)*($B$2:$B$100=$B2))>1

Excel 365 : Comment extraire doublon d'une plage sur Excel en moins de 6 min.
Excel 365 : Comment extraire doublon d’une plage sur Excel en moins de 6 min.

=SOMMEPROD(($A$2:$A$100=$A2)*($B$2:$B$100=$B2))>1

Excel 365 : Comment extraire doublon d'une plage sur Excel en moins de 6 min.
Excel 365 : Comment extraire doublon d’une plage sur Excel en moins de 6 min.

Extraction dans la feuille active

Excel 365 : Comment extraire doublon d'une plage sur Excel en moins de 6 min.
Excel 365 : Comment extraire doublon d’une plage sur Excel en moins de 6 min.
  • Cliquer sur A1
  • Données/Filtre/Filtre élaboré
  • Copier vers un autre emplacement
  • Critère: E5:E6
  • Destination :E8:F8
Excel : Extraction dans la feuille active version manuelle
Excel : Extraction dans la feuille active version manuelle

Code VBA :

Suite exemple avec extraction dans la feuille active, maintenant automatisons avec le code VBA

Extraction sans doublon : si nous voulons extraction avec ( Mettre False pour Unique :=False)

Sub ExtraitDoublons()
Sheets("Tuto_ExtraireDoublons").Range("A1:B1000").AdvancedFilter Action:= _
xlFilterCopy, CriteriaRange:=Sheets("Tuto_ExtraireDoublons").Range("E5:E6"), _
CopyToRange:=Range("E8:F8"), Unique:=True
End Sub
Excel 365 : Comment extraire doublon d'une plage sur Excel en moins de 6 min.
Excel 365 : Comment extraire doublon d’une plage sur Excel sans Doublon sur en sortie
Excel 365 : Comment extraire  les non-doublons d'un plage sur Excel sans Doublon en sortie
Excel 365 : Comment extraire les non-doublons d’un plage sur Excel sans Doublon en sortie

TUTO :

VERSION YOUTUBE :

Recevoir la newsletter

Inscrivez-vous maintenant et recevez un e-mail les fois où je publie du contenu.

I agree to have my personal information transfered to AWeber ( more information )

Je hais les spams. Vous pouvez vous désinscrire à tout moment.

Taggé .Mettre en favori le Permaliens.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *